FANDOM


Removed the parts about checking the Monument duplicate times. It will give you a short cutscene but they are not required. They simply repeat what you were told to do in the initial cutscene like is used in hundreds of quests and missions in case you forget what to do or where to go. --JTimmons 21:27, April 29, 2010 (UTC)

XBOX 360 USERS: Maybe it's just me, but I tried getting access to this quest several different ways. I have completed the prerequisite and the quest shows up as complete. when I attempt to start this quest, what exactly do I do FIRST? Previous quests in this series say "Zone in to Windurst (S)" yet this quest does not say Zone in to Windurst (S). This quest also matches some of the other quests in the series in that the START NPC is an NPC that does not exist anywhere in the game aside from cutscenes "Lehko Habhoka" ... so here is my question to people who have actually completed this quest: HOW can you start this quest? Because the START NPC cannot be physically found in the game. And the FIRST STEP is not "Zone in for a cutscene" ... it is "Talk to Dhea Prandoleh for a cutscene." If this really were the case, then the START NPC should be Dhea, not Lehko. I tried zoning out and zoning back in, and I got no such cutscene with Lehko like I usually got before. If anyone knows how to get this quest, PLEASE write back, or email me at overgryph@yahoo.com. Meanwhile I'm putting a note on the main page about this issue. --Overgryph 02:19, February 18, 2010 (UTC)

Dhea is, in fact, the start NPC. The quest flags in log after speaking with Dhea and receiving the first cutscene. --JoQuo711 19:23, March 20, 2010 (UTC)


Got this up to where I'm currently stuck. The cutscenes say that we're supposed to go through the tunnel where we fought off the waves of Yagudo during A Manifest Problem, but I checked the entrance you use for that quest, and it only says "There is no response..." I tried talking to Rotih Moalghett to see if maybe you need another key, but she simply gives her normal dialogue. So for now, I'm just running around checking any doors I can find. I'll update if I can find what to do next. --Kyrie 23:29, November 9, 2009 (UTC)

I am trying the BC at the moment, and as SAM75/DNC37 with 286 evasion skill, +20 evasion, and Seigan+Third Eye, these goblins are completely owning me. They hit me for 100+ with 375 defense (and Sigil, though I doubt they are EM or lower anyway), and are VERY accurate. I wouldn't recommend trying to solo this. :( --Kyrie 04:34, November 10, 2009 (UTC)

Solo'd this last night as a 75 RDM/NIN. Went to F-9 on the first map, and then headed north following the path on the second map, until the NPCs stopped and the mission was over. The goblins are (mostly) avoidable, and I didn't see a single Yagudo after the first large room. Had to stop the NPCs intentionally to clear out a total of three crabs, but that was the only fighting I ended up doing. If you're looking to solo this, be patient and try to avoid the goblins entirely. If you *do* get one, they don't attack all that quickly, blink-tanking should be an option, but they do indeed hit like a truck. My attempt as RDM/WHM didn't go well at all, could only bring a goblin to half HP before I had to teleport out. If you're a mage, I'd also advise bringing accuracy gear, as the goblins were rather evasive, and on the magic resistant side as well. A duo would have almost no difficulty, so long as one of the pair could tank reasonably well. Good luck everyone! --Emperor 19 17:06, November 12, 2009 (UTC)


  • Easily duoed by two blu, I'm sure almost any duo can manage it, maybe even solo. The suggested path was very easy, had to fight 3 mobs that were not dangerous to a duo at all.
  • Easily soloed by a 75blu/nin. Following the path suggested above, only needed to fight 1 crab. would say this is soloable by most any job at 75.
  • Easily soloed by 75RDM/BLM. Followed path as suggested above, didn't need to fight anything at all. You have plenty of time to do this even if mother/child should run off.
  • Soloed by 75 BLU/NIN. Didn't fight anything, took the west, south, west path then north route on the next map. girl ran off once cuz i wasn't careful. took all of 10 minutes. --Seanross
  • Soloed by 75 Nin/dnc. Had to kill 1 gob wasting some time and still win.
  • Soloed by 75 DRK/SAM. Killed 1 gob and 1 crab (because I grew impatient). Mobs seem to be DC to EMish, hit me for about 100 (Dread Spikes dmg wasn't resisted).
  • Soloed by DRG75/WHM37 with some difficulty. Followed the suggested path on main page. Only killed 1 Goblin and 1 Crab.
  • Easily soloed by 75SMN/WHM. Had to kill 1 Goblin in the first large room blocking the way.
  • Just soloed this on DNC75, though I would have passed it on any job. Level 1 even. I didn't engage a single mob. It was really easy as long as you're patient for mobs to cooperate. You really do have tons of time to get them through the area. --Ferretclaw 09:20, March 22, 2010 (UTC)
  • Soloed as 75 BLU/NIN. Patience is the key! I regularly stopped the mother/daughter - they don't hug the walls as well as you can but I only had one minor issue in the big room on the first map. On the second map the daughter ran off at the first junction but she only went back to the end of the first map. From there I went north but decided to kill a crab in the northern-most room to save a bit of time - was tougher than I thought but no real issues. From there I continued south-west to finish the quest. --Arekkusu May 28th 2010


There appears to be a glitch by which if you bring the mother to the endpoint while telling the kid to stay at a certain point, the quest becomes impossible to complete. The mother will stay at the endpoint, and the kid won't respond at all. Even aggroing a crab and bringing it right in front of the kid will not elicit a reaction. I have only done this once, but I'm assuming this isn't by design as the clock is still ticking with no quest fail message. I've only done this once.

--Saikouoffenrir 22:27, March 6, 2010 (UTC).

Community content is available under CC-BY-SA unless otherwise noted.